C-Command Software Forum

Some emails could not be imported into Apple Mail

Hello Michael!

The image 2021-12-27 at 22.15.44-EagelFiler-App.png shows 5 test emails in the EagleFiler interface.

Using the Apple Mail import function I tried to import the mbox file from EagleFiler into Apple Mail.

Images
2021-12-27 at 22.17.27.-Apple-Mail-Import-Dialog.png
2021-12-27 at 22.18.01-2021-EagelFiler-Files-mbox.png

An error message occurred in Apple Mail when importing:
Image 2021-12-27 at 22.18.12-Apple-Mail-Import-Error.png

Some emails could not be imported. The partially imported mailboxes are in the “Imported” mailbox in the mailbox list.

The image 2021-12-27 at 22.19.57-Apple-Mail-Import-result.png shows the import result of Apple Mail.
The e-mail “Test 1” is missing.

I can provide you with the test files by email if needed.

Many greetings, Carsten





Unfortunately, Mail did not say why it couldn’t import the “Test 1” e-mail. Perhaps there is something wrong with the mbox file or perhaps there’s a bug in Mail. If you would like to send me (off forum) the mbox file I can take a look at it, or you could try importing into a different mail client (such as Thunderbird) and see whether that works better.

Hello Michael,

Thank you very much for your answer. The directory was previously recreated in Apple Mail. Subsequently, the 5 test mails were sent to my e-mail address and moved to the mail directory/mailbox. Test mail 5 contains a file attachment.

I will send you the test data by mail or download link.

MacBook Pro, M1, 2020
macOS: Version 11.6.2 (20G314)
Mail: Version 14.0 (3654.120.0.1.13)
EagleFiler: Version 1.9.6

Best regards,
Carsten

Sorry, but I’m not sure what this means. Which directory? Previous, meaning before importing from EagleFiler? If it was recreated, does that mean that at some point you had deleted it?

Thanks. It looks like Mail is getting confused because the first test message had an empty body.

Hello Michael!

In Apple Mail, 5 test emails were created and moved to a mailbox in the left sidebar of Apple Mail. I’ll send you a short video about this in a moment.

Thanks. It looks like Mail is getting confused because the first test message had an empty body.

Yes, there seems to be a problem with this if the email body is empty. Since I often send myself mails as notes that only consist of a subject line without an email body, this can happen.

The behaviour is reproducible, see
2021-12-30-EagleFiler-Test-1.mp4 (e-mails with subject and body)
2021-12-30-EagleFiler-Test-2.mp4 (e-mails with subject, without body)

Can the problem be solved with the help of EagleFiler?

Thank you very much for your efforts.

Many greetings,
Carsten

For the next version of EagleFiler, I’ll look into whether it can “repair” such messages on import or export so that Mail will be able to import the mbox file properly.

Great, perfect. Then the app is bought.

This is now implemented in the public beta of EagleFiler 1.9.7.

Thanks! :slight_smile: