C-Command Software Forum

Spam Sieve has lost its accuracy on my Macs

Over the past month, more and more spam is getting past Spam Sieve. And most of it is so obviously spam. For instance, the word Viagra is in the from address, the subject line, even the content. And that’s just one example.

Is this happening for everyone, or is there a way to reset SS so that it becomes as accurate as it used to be.

thanks for any suggestions.

If really obvious spam messages are getting into your inbox, the most likely explanation is that your mail program is not asking SpamSieve to filter them. Please start by checking the log.

thanks, Michael. I’m checking out those instructions now.

I’ve had this same issue…
I too have encountered this problem of SpamSieve just recently allowing major amounts of obvious spam through. The app has worked great for over a year. Now all of a sudden I am getting massive amounts of spam again. I often receive the same messages even though I have trained them as spam. I have not made any changes to the SS settings… ??? Any suggestions are appreciated. Thanks.

Please check the log to see whether SpamSieve is getting these wrong or whether it’s not being asked to filter the messages.

Thanks, but…

Thank you for the quick reply! I had actually done that but all messages only indicated that they were “trained”.

I have now re-installed the Entourage scripts, deleted my old rule and created a new one. (I only have that one rule.) I relaunched both apps and trained about 50 messages after moving them from my junk folder to my inbox.

So far so good, but do you have any suggestions for why your filter might decide to stop catching spam if no changes were made to it’s or Entourage’s preferences? Just trying to avoid this from happening again.

Thanks!

Then SpamSieve didn’t let them through; it never even saw them.

It was already trained, so there’s no need to train it with 50 messages. One is sufficient to check the setup.

Most likely, one of the script files was corrupted. There’s an OS bug that can cause this after a script has been run many times. Reinstalling fresh copies of the scripts will get it working again.

Yes, something is now different
I’ve also noticed that something has changed. I had to replace my HD, and reloaded Eudora 6.2, and then spamsieve. Previously spamsieve worked great, and once is designated a site as junk it stayed there in the future. Now I keep designating the same emails as junk, but they keep coming to my In box.

Have you figured out what has changed? If I say the X-10 email is junk (from the same source), why does it keep coming to my in box?

Thanks.

Please check the log to see whether this is actually SpamSieve’s fault.

log is empty
hmm, interesting-the only shows the recent date that spamsieve was launched. There are NO emails, so it seems that for some reason Spamsieve is not properly installed. I reinstalled it, but it still doesn’t seem to detect any emails. I’ve not had this problem in several years of using spamsieve, so am puzzled over what to do get it reinstalled properly.
Thanks.
-wayne

Please see this page.

how do delete message plugins?
Thanks for the link. All the boxes are properly checked, but there are 8 installed message plugins, about which I don’t know anything. Some are not related to spam fileter, but in eudora I can’t find any way to delete them. I guess i could try trashing the plugin folder, but I don’t know if this is a good idea.
More importantly, there’s NO spamsieve plugin listed, even though i installed it and it is running.
Is it something obvious?
Thanks.

You shouldn’t need to delete any Eudora plug-ins. You just need to make sure that the SpamSieve plug-in is loaded.

How do you know it’s running? If the SpamSieve plug-in doesn’t show up in Eudora’s About Message Plug-Ins window, it’s not running. Please make sure that you’ve chosen Install Eudora Plug-In from the SpamSieve menu and that afterwords you can see the SpamSieve plug-in in the folder:

/Users/<username>/Library/Application Support/Eudora/PlugIns/

as well as in About Message Plug-Ins.

dumb me
Ah, it’s been so long since i first installed spamsieve (only done the upgrades) that I completely forgot about the plug installation. Thanks for highlighting my decrepit memory!
Now the spamsiever 1.0.5 plug is there (along with a few other eudora things that are I guess OK)
Thanks again.
-wm

For the past few weeks, specific spams have been getting through. Namely V1agra and R3plica W4tch spams. Training as spam was not working so I added a rule to the block list. “Subject containing W4tch” to be added to block list, that was last week. I have attached the latest 3 (in a row) W4tch emails that have gotten through. (incidentally I added “W4tches”; “w4tch”; “w4tches” to the so called blocked list as well). I don’t know what else to do. It’s slightly maddening that a program that is SO amazing 99.9999999% percent of the time is letting these things through I specifically banned. Thanks for your help!

Predicted: Good (0)
Subject: Reliable w4tches for everyone at Prest1ge Repl1cas
From: removed
Identifier: jtSHbrydwgfwYwU08Ve17g==
Reason: sender <michelle@mmproductions.com> in address book
Date: 2007-10-24 11:37:28 -0700

Trained: Spam (Manual)
Subject: Reliable w4tches for everyone at Prest1ge Repl1cas
Identifier: jtSHbrydwgfwYwU08Ve17g==
Actions: added rule <From (name) Is Equal to “Charles Cowan”> to SpamSieve blocklist, added to Spam corpus (594)
Date: 2007-10-24 11:37:37 -0700

Mistake: False Negative
Subject: Reliable w4tches for everyone at Prest1ge Repl1cas
Identifier: jtSHbrydwgfwYwU08Ve17g==
Classifier: Address Book
Score: 0
Date: 2007-10-24 11:37:42 -0700

As you can see from the log entries that you quoted, SpamSieve predicted this message to be good because the sender is in your address book. Creating a blocklist rule won’t help, because (for safety reasons) the address book has a higher priority than the blocklist. If the “michelle@mmproductions.com” address is one of your own, please see this blog post for how to exclude it so that SpamSieve will filter messages from that address according to their content. If it’s not your address, your choices are to remove it from your address book or to uncheck Use Mac OS X Address Book in SpamSieve’s preferences.

Thank you Michael! I have checked “Exclude my Addresses”. I am sure that will do the trick!

Didn’t quite do the trick
It’s been almost two weeks now. For the first week I left the “Exclude my addresses” box un-checked and spamsieve was letting through spam that had from addresses that were in my address book. I figured I had done the opposite of what I was supposed to so I checked the “Exclude my addresses”. No difference. I still get spam that has a from field that is from someone in my address book despite my specific block list “subject contains” rule and many, many “Train as spam” with both checked and unchecked “Exclude…” box. Any other suggestion?

It should be checked.

Like I said, the blocklist has lower priority than the address book. It makes no difference which blocklist rules you have or what training you’ve done if the address is in Address Book and you’ve told SpamSieve to use Address Book.

I also said that you needed to do one of the following:

  1. Add the address to your “Me” card in Address Book.
  2. Remove the address from Address Book.
  3. Uncheck Use Mac OS X Address Book in SpamSieve’s preferences.

Which did you do?

Same problems since upgrade to 2.6.6
I have had many of the same problems as Adamant Finn. The problem is the 2.6.6 update, as the problems started immediately after the installation.

Another issue is that when I view the log, it says some of these addresses are in my address book, and that is why they got through. None of the addresses are in my address book.

It has also automatically trained as good a number of spam messages that formerly never got through – and added them to the whitelist. ( NewDesignerWatches, etc.)

While I have followed many of the suggestions made to others, with no result, none of this explains why we are having these problems only since the 2.6.6 update.

Any new information on this? Thanks.