C-Command Software Forum

Spam Sieve marks messages with brown color

Hi,

After upgrading to Mavericks, Spam Sieve 2.9.10 is marking some messages with a brown color, the same color that Mail.app uses to mark email as Spam. This is despite the fact that the Junk Filter in mail.app is disabled.

Any help would be appreciated.

Thanks.

Are you viewing the messages using the same Mac that SpamSieve is running on?

Yes Sir.

I’ve attached a screenshot.

Screen Shot 2013-10-23 at 1.03.30 PM.png

The same thing is happening to me. Even though I have the Apple Junk Filter off its on.

Confirmed here as well. It seems as every incoming message is ‘marked as spam’. Preferences -> Junk Mail is disabled.

Additional information that might be useful. I have the following installed:

  • MailTags 4.0b2512
  • Mail Act-On 3.0b941M
  • GPGMail 2.1

Which mailbox (or smart mailbox) is that? Does SpamSieve’s log show those three messages as “Predicted: Spam”?

I’m not seeing this on my Mac. What makes you say that it’s on? Are the Junk commands enabled in the menus? Are there messages outside the Spam mailbox that are marked as junk? Are the messages in the Spam mailbox still multi-colored by SpamSieve? Does it help if you turn Apple’s filter on and then off?

Yours is the only report I’ve heard of that. I suggest temporarily uninstalling the other Mail plug-ins to see whether that makes any difference. Also, I wonder whether you have a server-side filter that’s marking the messages as junk, and this just wasn’t evident before because Mail used to not display the junk status when its filter was off.

That’s my Inbox (imap account, not a smart mailbox). No SpamSieve is listing it as Good. See below.

Predicted: Good (1)
Subject: Your new password for C-Command Forums
From: forums@c-command.com
Identifier: w94CvoNUumtRhL4NAFG/ww==
Reason: (
"forums@c-command.com"
) matched rule <From (address) Is Equal to "forums@c-command.com"> in SpamSieve whitelist
Date: 2013-10-23 15:28:17 +0000

Yes I get the brown, “You labeled this a Junk…” on every spam email in my spam folder.

Screenshot-2013-10-23-13.14.09.jpg

I don’t think so.

I don’t notice another color.

No I have tried this several times.

https://discussions.apple.com/message/23482468?ac_cid=op123456#23482468

I’m also seeing the same behavior and while the default was for Apple Spam to be on after the update, it’s since turned off.

I have several emails that go through my website provider A2 Hosting. I have turned off all filtering at the host level through Spam Assassin (It doesn’t work that well anyway) to see if the email is still flagged.

The problem might be with gmail accounts only as the only accounts listed in my junk folder on my mac are gmail accounts.

Same for me, I’ve turned off Spam Assassin on Server but it doesn’t make a difference.

ok I had a spam message from one gmail accounts and it did not have the Junk brown bar but then I trained as spam and it then put the junk brown bar on the email. So it is seeing the spamsieve the same as server-side spam.

I don’t think it’s only gmail as I don’t have any gmail accounts set up in mail.app but the problem still exists.

yeah the problem is the way mail is interpreting spamsieve

Perhaps your mail server’s spam filter (e.g. Gmail) marked it as spam? It is normal for Mail (on Mavericks) to show messages that were marked as junk in brown, even when Mail’s own junk filter is off. This is not really related to SpamSieve.

You’re just seeing the brown bar above the message, not the message itself brown in the list (like marxster is seeing), right? If so, I think that’s normal.

When you train a message as spam, SpamSieve tells Mail that it’s spam. SpamSieve has always done this so that (a) Mail hides the images for spam messages to protect you, and (b) Mail’s own junk filter stays up-to-date in case you ever want to use it. The difference with Mavericks is that Apple Mail now shows more of its own junk filter user interface when it’s turned off. You should ignore this if you’re using SpamSieve. That is, always choose “SpamSieve - Train as Good” rather than clicking the “Not Junk” button.

My server’s spam filter is turned off. I don’t have Gmail, this is an imap account on my own domain. I don’t see where mail would get marked as junk if my server isn’t doing it and the Junk Filter is turned off.

The brown color doesn’t even disappear after you click “this is not junk”. See screenshot.

Screen Shot 2013-10-23 at 4.30.42 PM.png

Do you mean you are seeing messages outside the Spam mailbox colored brown in the list? Or that you see the brown strip with the “Not Junk” button?

SpamSieve isn’t marking the messages as junk, since the log showed that it thought they was good. Do you have any other Mail plug-ins installed? Or this may simply be due to a bug in Mail.

Almost all messages were marked brown. See attachment.

There is no server-side filtering going on - it’s an IMAP account on a TextDrive shared server. SpamSieve is the only thing I use to filter spam.

I’ve uninstalled the 3 plugins and new messages are no longer being labelled as spam. In my case, it seems to be an interaction between SpamSieve and one/more of the other plugins. I’ll try to determine the relationship.

Napkin.napkin 10-23-13, 2.02.51 PM.png