SS3 - Training as Spam doesn't move message to Spam Folder

Hi. I recently updated to SpamSieve 3.0 and am noticing when I click on a message, Train as Spam, the message seems to change color but it doesn’t move to the designated Spam folder. If after it’s marked as Spam, I right click and hit apply rules, it moves. I never saw this behavior in the previous version of SpamSieve. Any help is appreciated. Thank you.

Is this with a POP account, perhaps?

Did you designate the Spam folder here:

Otherwise, if it’s set to Junk there, you may need to fix the configuration for your Junk mailbox.

It is indeed a POP account. Here’s a screen cap of the settings:

I am running 13.6’s Apple Mail client in case that information is helpful. I did check the configuration for the Junk mailbox and it looks to be correct. I see it on the left side bar for my POP account.

I will say that it the messages that SpamSieve is auto-marking as spam are going to the Spam folder as per the previous version’s recommendations/rules.

Does your account’s name appear in Mail’s sidebar? If so, is there a Junk mailbox under it?

Yes it does and yes the Junk mailbox is under it.


If you have a spam message in the inbox and choose Message ‣ Move to Junk in Mail, does it move to that Junk mailbox?

Also, please try changing the setting in SpamSieve to the Trash mailbox and then back to the Junk mailbox.

Yes, it does.

Done. Changed it to Trash, quit mail and SpamSieve. Fired Mail back up and changed it back to Junk.

After the change from Junk to Trash back to Junk the Train as Spam command is now moving messages into the junk folder without having to right click and select Apply Rules.

Quick question…the auto-filtered ones are still going to the folder named Spam. Is this expected behavior?

Yes, if that’s how you configured the SpamSieve rule in Mail’s preferences. You could change it to All Junk if you want.

Thank you @Michael_Tsai !

Great. I believe the underlying bug is fixed in SpamSieve 3.0.1b3 so that this won’t be necessary for other people.

Thank you, that’s great news!