C-Command Software Forum

"Train as Good" is not moving messages, too

Been a SpamSieve user for long, long time. Yesterday reformatted MBP with Mountain Lion and installed everything from scratch. Using Apple Mail with three accounts: Exchange, Gmail, and .Mac/MobileMe/iCloud.

Ran a (non-SpamSieve) rule against all mail. All messages were processed by SpamSieve and several hundred (335 to be exact) were moved to the “Spam” mailbox on my computer.

Went through the list and selected most of the messages (cause they were ‘good’) and selected the Message --> SpamSieve - Train as Good menu option. They were added to the log as “Trained: Good (Manual)”, but did not move back to their original location. :frowning:

I did not try to move any training to the new machine from backup. Checked both the rule as well as the mailbox name (“Spam”) and both look good.

Mountain Lion 10.8.2, Apple Mail 6.1.1498, and SpamSieve 2.9.5

I’m not sure that’s possible with Apple Mail, as it likes to apply all the rules at once.

If you’re going to apply the SpamSieve rule to lots of messages at once, it’s best to turn off auto-training first.

Please check Change Settings to make sure that it’s set to move good messages back to the inbox.

I’m having the same experience. Spam Sieve 2.9.5, Mail 6.1 OSX 10.8.2

Spam Sieve no longer moves good messages to the inbox, despite having the rule set up that way. Verified with change settings. No change.

The rule doesn’t matter, only Change Settings. What is the name of the mailbox that the message is in when you use “Train as Good”?

Also, you can click here to tell SpamSieve to bring up a dialog box if an error occurs. That may help us figure out what’s going wrong.

Mailbox name is “Spam”.

I also clicked the posted preference/link. Is it easy to turn off, when we’re done, or do I just leave it?

Error message is; “Mail got an error. An error of type 8 occurred.”

It’s safe to leave it on, but if the error dialogs are annoying you can click here to turn it off.

Thanks. I think I know what’s causing this—I’m guessing that the problem is restricted to messages whose recipient addresses don’t match any of your account addresses. Please contact me via e-mail, and I’ll send you a beta version of SpamSieve to work around this problem.

(Also, in case anyone is finding this thread by search, I think it actually says “An error of type 8 occurred.”)

Sent

I did this at the end of creating a rule, so it did seem to apply to the selected mailbox for only the rule that I created. But perhaps not.

Got it.

Everything seemed correct here. Still not moving messages back to the Inbox. Could be the address thing you mentioned later in the thread. (There’s a discrepancy between my e-mail account address and the actual address I receive e-mail on.) Got the “type 8” error, so it is probably the e-mail address issue.

It’s confusing, but Mail actually applies all the rules after you edit one and click Apply.

OK, send me an e-mail, and I’ll send you the beta to work around this.

Mine neither
Since installing on a new laptop my messages also don’t move back to the inbox after clicking “Train as Good”
I’ve updated the settings under Message-Spamsieve-Change Settings

Please send me an e-mail, and I’ll send you a beta version that works around this issue.

I’m running into the same problem as everyone else, but it’s happening with both Train as Good and Train as Spam. Pressing either does not move the messages to their expected folder. I’m running Mountain Lion 10.8.2 and SpamSieve 2.9.5. I’ve checked the SpamSieve log and it’s not showing any sort of entries from my manual ‘Mark as Spam’ attempts.

I found a applescript from snowleopard here on the forums and that moved the messages just fine.

Please send me an e-mail, and I’ll send you a beta version that works around this issue.

Me too…
Sadly, I’m suffering from the same thing. For some reason SpamSieve insists on sending messages from my other half to the spam box. Doesn’t go down well when she sees what’s happened!

Hope you’ll be able to fix it soon. Thanks for the good work.

Cheers,

Ol.

It sounds like you’re seeing a different issue. Please contact me via e-mail, and include the information described on this page.

re: the beta update
I “assume” if there is a beta update, then the problem is recognized and a fix is in the works and will be available soon.

I can tolerate training as good and manually moving from the spam folder to my inbox for now.

Is there any projected time frame when this beta fix will be pushed out in an update?

If it’s before the end of the year, I’ll just tolerate the problem. Otherwise I might want to shoot you an email for the beta.

Probably in December. However, there’s always the possibility that you’re seeing a different problem with the same apparent symptoms. So that’s why I recommend that everyone who is seeing this issue try the beta to make sure that it fixes it for them.

Michael,
Thank You for the beta version. It does indeed move mail from the Spam folder to the inbox when I “Train As Good”.

FYI, it does not necessarily move the mail to the proper inbox.

For example, my Inbox is set up with a Gmail acct, a Yahoo acct, and 5 pop accts. in that order. Today I found a good email to one of my POP accts in the Spam folder. I trained it as good, it disappeared from the Spam folder and showed up in the Gmail folder of my Inbox. I’m not sure, but I thought that in older versions, everything went back to it’s associated folder inbox.

I had thought that might have happened shortly after I installed the beta, but I passed it off as an error on my part, with a mental note to watch for it next time. Sure enough, it did.

Perhaps it sent the good mail to the first folder in the list? I’ll make a mental note pay closer attention to this next time if this is a concern on your part.

Thanks again.